How can we help?

Autograph 3.3.10 not working after Win 10 Anniversary update

Get a system error saying "ext-ms-win-gdi-desktop-I1-1-0.dll is missing". Cannot run application. Email to support no response.
Advice please.

12 votes
Vote
Sign in
(thinking…)
Password icon
Signed in as (Sign out)
You have left! (?) (thinking…)
Richard Williams shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
AdminStephen Whipp (Mr, Autograph) responded  · 

Apologies for not catching your emails in our Support system for some reason. Here is some info regarding a fix for this error:

This issue has been caused by the recent Windows 10 “Anniversary Update”. It seems that Microsoft have inadvertently removed a DLL that some applications require. No doubt this will be fixed in a subsequent update, but in the meantime, a ‘dummy’ DLL, that should resolve the problem, can be downloaded from:

http://www.autograph-maths.com/downloads/windows/ext-ms-win-gdi-desktop-l1-1-0.zip

For a single user, not running from a network install, this is relatively easy to install. Simply unzip the attached zip file and copy the contained DLL into your Autograph folder. This is generally located at: C:\Program Files (x86)\Autograph 3.3. For network users, we are currently working on a patch. However, in the meantime, you can use Group Policy to push the DLL file out to all client machines.

Hope this helps.

Regards
Autograph Support

12 comments

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Bass Mann commented  ·   ·  Flag as inappropriate

    I have also tried this fix, but I am still having no luck.
    I have emailed support, but still I have not had a response yet.

  • Rick Warner commented  ·   ·  Flag as inappropriate

    OK, I've struggled with the network install of this one legged dog for a long time. If you can't start it after install but it appears in task manager :

    1. Create a new folder in Program Files (x86) called Autographx ( or whatever you want )
    2. Copy all of the files ( not folders ) from the Autograph 3.3 folder into the new folder
    3. Run agraph.exe from the new folder

  • David commented  ·   ·  Flag as inappropriate

    I have tried EVERTHING to get Autograph 3.3 running in W10. The best that I do is to get Autograph 3.2 running unlicensed. My emails to support go unanswered. We have an RM Connect 4.5 network

  • Sroor Asaad commented  ·   ·  Flag as inappropriate

    Still having issues with Autograph on Windows 10. The program appears to do nothing when you run it however it is running in task manager. Anyone with a fix for this please?
    Thanks

  • Jerdno commented  ·   ·  Flag as inappropriate

    Use 32bit version of the DLL instead of 64bit version.

    1.) Download "anniversary-patch-for-owlnext.zip" from here:
    https://sourceforge.net/projects/owlnext/files/misc/

    2.)Copy "ext-ms-win-gdi-desktop-l1-1-0.dll" into Autograph installation folder.

    USE THE 32 BIT VERSION!!! (...\anniversary-patch-for-owlnext.zip\Win32\Release\ext-ms-win-gdi-desktop-l1-1-0.dll)

  • Carolyn While commented  ·   ·  Flag as inappropriate

    Still having issues with Autograph on Windows 10. The program appears to do nothing when you run it however it is running in task manager. Anyone with a fix for this please?
    Thanks

  • Tim commented  ·   ·  Flag as inappropriate

    Thanks Stephen, that worked fine.

    Might be worth mentioning that I did a full reinstall of Autograph after the W10 upgrade. May not be necessary.

  • Richard Williams commented  ·   ·  Flag as inappropriate

    This fix succeeds in getting rid of the error message for the missing DLL but Autograph crashes before start up - advice please!

  • Tim commented  ·   ·  Flag as inappropriate

    You are not alone - I'm emailing support in case they don't notice.

Feedback and Knowledge Base